re = /^http(s)?:\/\/(my.|writer.)dek-d.com\/.*\/view(longc)?.php\?id=(\d)*(\&chapter=(\d)*)?$/im
str = 'https://writer.dek-d.com/view.php?id=1714407&chapter=13'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end