import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^http(s)?:\\/\\/(my.|writer.)dek-d.com\\/.*\\/view(longc)?.php\\?id=(\\d)*(\\&chapter=(\\d)*)?$";
final String string = "https://writer.dek-d.com/view.php?id=1714407&chapter=13";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}