// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)https\:\/\/www\.bugaboo\.com\/(us|gb)-.{2}\/.*(952000ZW01|951000ZW01).html").unwrap();
let string = "https://www.bugaboo.com/gb-en/accessories/travel-cot/bugaboo-stardust-uk-black-952000ZW01.html
https://www.bugaboo.com/gb-en/accessories/travel-cot/bugaboo-stardust-uk-black-952000ZW01.html
https://www.bugaboo.com/us-es/accesorios/travel-cot/bugaboo-stardust-na-black-951000ZW01.html
952000ZW01 is uk
951000ZW01 is us
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}