package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https\:\/\/www\.bugaboo\.com\/(us|gb)-.{2}\/.*(952000ZW01|951000ZW01).html`)
var str = `https://www.bugaboo.com/gb-en/accessories/travel-cot/bugaboo-stardust-uk-black-952000ZW01.html
https://www.bugaboo.com/gb-en/accessories/travel-cot/bugaboo-stardust-uk-black-952000ZW01.html
https://www.bugaboo.com/us-es/accesorios/travel-cot/bugaboo-stardust-na-black-951000ZW01.html
952000ZW01 is uk
951000ZW01 is us
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}