$re = '/https\:\/\/www\.bugaboo\.com\/(us|gb)-.{2}\/.*(952000ZW01|951000ZW01).html/m';
$str = 'https://www.bugaboo.com/gb-en/accessories/travel-cot/bugaboo-stardust-uk-black-952000ZW01.html
https://www.bugaboo.com/gb-en/accessories/travel-cot/bugaboo-stardust-uk-black-952000ZW01.html
https://www.bugaboo.com/us-es/accesorios/travel-cot/bugaboo-stardust-na-black-951000ZW01.html
952000ZW01 is uk
951000ZW01 is us
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);