const regex = /https\:\/\/www\.bugaboo\.com\/(us|gb)-.{2}\/.*(952000ZW01|951000ZW01).html/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https\\:\\\/\\\/www\\.bugaboo\\.com\\\/(us|gb)-.{2}\\\/.*(952000ZW01|951000ZW01).html', 'gm')
const str = `https://www.bugaboo.com/gb-en/accessories/travel-cot/bugaboo-stardust-uk-black-952000ZW01.html
https://www.bugaboo.com/gb-en/accessories/travel-cot/bugaboo-stardust-uk-black-952000ZW01.html
https://www.bugaboo.com/us-es/accesorios/travel-cot/bugaboo-stardust-na-black-951000ZW01.html
952000ZW01 is uk
951000ZW01 is us
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}