#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https\:\/\/www\.bugaboo\.com\/(us|gb)-.{2}\/.*(952000ZW01|951000ZW01).html"
Local $sString = "https://www.bugaboo.com/gb-en/accessories/travel-cot/bugaboo-stardust-uk-black-952000ZW01.html" & @CRLF & _
"https://www.bugaboo.com/gb-en/accessories/travel-cot/bugaboo-stardust-uk-black-952000ZW01.html" & @CRLF & _
"" & @CRLF & _
"https://www.bugaboo.com/us-es/accesorios/travel-cot/bugaboo-stardust-na-black-951000ZW01.html" & @CRLF & _
"" & @CRLF & _
"952000ZW01 is uk" & @CRLF & _
"951000ZW01 is us" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")