import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https\\:\\/\\/www\\.bugaboo\\.com\\/(us|gb)-.{2}\\/.*(952000ZW01|951000ZW01).html";
final String string = "https://www.bugaboo.com/gb-en/accessories/travel-cot/bugaboo-stardust-uk-black-952000ZW01.html\n"
+ "https://www.bugaboo.com/gb-en/accessories/travel-cot/bugaboo-stardust-uk-black-952000ZW01.html\n\n"
+ "https://www.bugaboo.com/us-es/accesorios/travel-cot/bugaboo-stardust-na-black-951000ZW01.html\n\n"
+ "952000ZW01 is uk\n"
+ "951000ZW01 is us\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}