// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\w+(?:[.\-+!%]\w+)*@\w+(?:[.\-]\w+)+$").unwrap();
let string = "djsuhuh@gmail.com
jdh0-@gmail.com
gdfsr!@yahoo.com
dhalfush%bvc@gmail.com
jgff-dhdhdg-hhh@gmail.com
example.index@gmai.com
lurdes@gmail.com
marina-souza@example.com
dhsu!jama@exam.com
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}