re = /^\w+(?:[.\-+!%]\w+)*@\w+(?:[.\-]\w+)+$/m
str = 'djsuhuh@gmail.com
jdh0-@gmail.com
gdfsr!@yahoo.com
dhalfush%bvc@gmail.com
jgff-dhdhdg-hhh@gmail.com
example.index@gmai.com
lurdes@gmail.com
marina-souza@example.com
dhsu!jama@exam.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end