#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\w+(?:[.\-+!%]\w+)*@\w+(?:[.\-]\w+)+$"
Local $sString = "djsuhuh@gmail.com" & @CRLF & _
"jdh0-@gmail.com" & @CRLF & _
"gdfsr!@yahoo.com" & @CRLF & _
"dhalfush%bvc@gmail.com" & @CRLF & _
"jgff-dhdhdg-hhh@gmail.com" & @CRLF & _
"example.index@gmai.com" & @CRLF & _
"lurdes@gmail.com" & @CRLF & _
"marina-souza@example.com" & @CRLF & _
"dhsu!jama@exam.com" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")