using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\w+(?:[.\-+!%]\w+)*@\w+(?:[.\-]\w+)+$";
string input = @"djsuhuh@gmail.com
jdh0-@gmail.com
gdfsr!@yahoo.com
dhalfush%bvc@gmail.com
jgff-dhdhdg-hhh@gmail.com
example.index@gmai.com
lurdes@gmail.com
marina-souza@example.com
dhsu!jama@exam.com
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}