import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\w+(?:[.\\-+!%]\\w+)*@\\w+(?:[.\\-]\\w+)+$";
final String string = "djsuhuh@gmail.com\n"
+ "jdh0-@gmail.com\n"
+ "gdfsr!@yahoo.com\n"
+ "dhalfush%bvc@gmail.com\n"
+ "jgff-dhdhdg-hhh@gmail.com\n"
+ "example.index@gmai.com\n"
+ "lurdes@gmail.com\n"
+ "marina-souza@example.com\n"
+ "dhsu!jama@exam.com\n\n\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}