const regex = new RegExp('^\\w+(?:[.\\-+!%]\\w+)*@\\w+(?:[.\\-]\\w+)+$', 'gm')
const str = `djsuhuh@gmail.com
jdh0-@gmail.com
gdfsr!@yahoo.com
dhalfush%bvc@gmail.com
jgff-dhdhdg-hhh@gmail.com
example.index@gmai.com
lurdes@gmail.com
marina-souza@example.com
dhsu!jama@exam.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}