import Foundation
let pattern = ##"""
^\#\s* # must start with "#" to indicate beeing a repo.
(?:@?@?(?!-)(?P<user>(?:[a-zA-Z0-9]|-(?!-))+[a-zA-Z0-9])(?![^\x00-\x7F]))? # Username part
(?:(?<=\#)|[/\s\.](?<!\v))(?P<repo>[a-zA-Z0-9_.-]+)$
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .allowCommentsAndWhitespace])
let testString = ###"""
#@luckydonald/bonbot
#@luckydonald.bonbot
#@luckydonald bonbot
#luckydonald/bonbot
#luckydonald bonbot
#luckydonald.bonbot
#luckydonald/.home
#luckydonald..home
#luckydonald .home
#/bonbot
#bonbot
#.bonbot
#bonbot
## Not allowed: ##
@luckydonald .home
luckydonald/home
##lol/bar
#@lilz
#@lol@huu
#lol wut lol
#-invalid/ho
#@-invalid/yo
#lolol-/möp
#möü/sdds
"""###
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)