package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^\#\s* # must start with "#" to indicate beeing a repo.
(?:@?@?(?!-)(?P<user>(?:[a-zA-Z0-9]|-(?!-))+[a-zA-Z0-9])(?![^\x00-\x7F]))? # Username part
(?:(?<=\#)|[/\s\.](?<!\v))(?P<repo>[a-zA-Z0-9_.-]+)$`)
var str = `#@luckydonald/bonbot
#@luckydonald.bonbot
#@luckydonald bonbot
#luckydonald/bonbot
#luckydonald bonbot
#luckydonald.bonbot
#luckydonald/.home
#luckydonald..home
#luckydonald .home
#/bonbot
#bonbot
#.bonbot
#bonbot
## Not allowed: ##
@luckydonald .home
luckydonald/home
##lol/bar
#@lilz
#@lol@huu
#lol wut lol
#-invalid/ho
#@-invalid/yo
#lolol-/möp
#möü/sdds`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}