$re = '/^\#\s* # must start with "#" to indicate beeing a repo.
(?:@?@?(?!-)(?P<user>(?:[a-zA-Z0-9]|-(?!-))+[a-zA-Z0-9])(?![^\x00-\x7F]))? # Username part
(?:(?<=\#)|[/\s\.](?<!\v))(?P<repo>[a-zA-Z0-9_.-]+)$/mix';
$str = '#@luckydonald/bonbot
#@luckydonald.bonbot
#@luckydonald bonbot
#luckydonald/bonbot
#luckydonald bonbot
#luckydonald.bonbot
#luckydonald/.home
#luckydonald..home
#luckydonald .home
#/bonbot
#bonbot
#.bonbot
#bonbot
## Not allowed: ##
@luckydonald .home
luckydonald/home
##lol/bar
#@lilz
#@lol@huu
#lol wut lol
#-invalid/ho
#@-invalid/yo
#lolol-/möp
#möü/sdds';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);