// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r##"(?mix)^\#\s* # must start with "#" to indicate beeing a repo.
(?:@?@?(?!-)(?P<user>(?:[a-zA-Z0-9]|-(?!-))+[a-zA-Z0-9])(?![^\x00-\x7F]))? # Username part
(?:(?<=\#)|[/\s\.](?<!\v))(?P<repo>[a-zA-Z0-9_.-]+)$"##).unwrap();
let string = "#@luckydonald/bonbot
#@luckydonald.bonbot
#@luckydonald bonbot
#luckydonald/bonbot
#luckydonald bonbot
#luckydonald.bonbot
#luckydonald/.home
#luckydonald..home
#luckydonald .home
#/bonbot
#bonbot
#.bonbot
#bonbot
## Not allowed: ##
@luckydonald .home
luckydonald/home
##lol/bar
#@lilz
#@lol@huu
#lol wut lol
#-invalid/ho
#@-invalid/yo
#lolol-/möp
#möü/sdds";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}