import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\#\\s* # must start with \"#\" to indicate beeing a repo.\n"
+ "(?:@?@?(?!-)(?P<user>(?:[a-zA-Z0-9]|-(?!-))+[a-zA-Z0-9])(?![^\\x00-\\x7F]))? # Username part\n"
+ "(?:(?<=\\#)|[/\\s\\.](?<!\\v))(?P<repo>[a-zA-Z0-9_.-]+)$";
final String string = "#@luckydonald/bonbot\n"
+ "#@luckydonald.bonbot\n"
+ "#@luckydonald bonbot\n"
+ "#luckydonald/bonbot\n"
+ "#luckydonald bonbot\n"
+ "#luckydonald.bonbot\n"
+ "#luckydonald/.home\n"
+ "#luckydonald..home\n"
+ "#luckydonald .home\n"
+ "#/bonbot\n"
+ "#bonbot\n"
+ "#.bonbot\n"
+ "#bonbot\n\n\n"
+ "## Not allowed: ##\n\n"
+ "@luckydonald .home\n"
+ "luckydonald/home\n"
+ "##lol/bar\n"
+ "#@lilz\n"
+ "#@lol@huu\n"
+ "#lol wut lol\n"
+ "#-invalid/ho\n"
+ "#@-invalid/yo\n"
+ "#lolol-/möp\n"
+ "#möü/sdds";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}