# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^\#\s* # must start with "#" to indicate beeing a repo.
(?:@?@?(?!-)(?P<user>(?:[a-zA-Z0-9]|-(?!-))+[a-zA-Z0-9])(?![^\x00-\x7F]))? # Username part
(?:(?<=\#)|[/\s\.](?<!\v))(?P<repo>[a-zA-Z0-9_.-]+)$
"""
test_str = ("#@luckydonald/bonbot\n"
"#@luckydonald.bonbot\n"
"#@luckydonald bonbot\n"
"#luckydonald/bonbot\n"
"#luckydonald bonbot\n"
"#luckydonald.bonbot\n"
"#luckydonald/.home\n"
"#luckydonald..home\n"
"#luckydonald .home\n"
"#/bonbot\n"
"#bonbot\n"
"#.bonbot\n"
"#bonbot\n\n\n"
"## Not allowed: ##\n\n"
"@luckydonald .home\n"
"luckydonald/home\n"
"##lol/bar\n"
"#@lilz\n"
"#@lol@huu\n"
"#lol wut lol\n"
"#-invalid/ho\n"
"#@-invalid/yo\n"
"#lolol-/möp\n"
"#möü/sdds")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.