re = /.*\.(\w{1,})$|(.*)/m
str = '/lib/kbd/console.trans/spacetoto
/lib/kbd/console.trans/spacetoto.txt
/lib/kbd/consoletrans/spacetoto
/lib/kbd/console.trans/space+toto
/integration/jenkins-IC-SLV4/workspace/RMIX_IMIR/trunk/.svn/entries'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result