const regex = /.*\.(\w{1,})$|(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\.(\\w{1,})$|(.*)', 'gm')
const str = `/lib/kbd/console.trans/spacetoto
/lib/kbd/console.trans/spacetoto.txt
/lib/kbd/consoletrans/spacetoto
/lib/kbd/console.trans/space+toto
/integration/jenkins-IC-SLV4/workspace/RMIX_IMIR/trunk/.svn/entries`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);