using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\.(\w{1,})$|(.*)";
string substitution = @"$1";
string input = @"/lib/kbd/console.trans/spacetoto
/lib/kbd/console.trans/spacetoto.txt
/lib/kbd/consoletrans/spacetoto
/lib/kbd/console.trans/space+toto
/integration/jenkins-IC-SLV4/workspace/RMIX_IMIR/trunk/.svn/entries";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}