use strict;
my $str = '/lib/kbd/console.trans/spacetoto
/lib/kbd/console.trans/spacetoto.txt
/lib/kbd/consoletrans/spacetoto
/lib/kbd/console.trans/space+toto
/integration/jenkins-IC-SLV4/workspace/RMIX_IMIR/trunk/.svn/entries';
my $regex = qr/.*\.(\w{1,})$|(.*)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";