import Foundation
let pattern = #"^\/([a-zA-Z\-]+\/)?(admin((\/[a-zA-Z0-9\-_&=?]*)*|$)|(user\/(login|password)(\/?\?[a-zA-Z0-9\-_&=]*|$)))$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/admin/valadas/gyfhsdfgsdjf/DHGSDJHFSF/sdjsdh?a=23&b=13
/user/password/?teste=1212&teste=1234
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)