package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\/([a-zA-Z\-]+\/)?(admin((\/[a-zA-Z0-9\-_&=?]*)*|$)|(user\/(login|password)(\/?\?[a-zA-Z0-9\-_&=]*|$)))$`)
var str = `/admin/valadas/gyfhsdfgsdjf/DHGSDJHFSF/sdjsdh?a=23&b=13
/user/password/?teste=1212&teste=1234
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}