import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\/([a-zA-Z\\-]+\\/)?(admin((\\/[a-zA-Z0-9\\-_&=?]*)*|$)|(user\\/(login|password)(\\/?\\?[a-zA-Z0-9\\-_&=]*|$)))$";
final String string = "/admin/valadas/gyfhsdfgsdjf/DHGSDJHFSF/sdjsdh?a=23&b=13\n\n"
+ "/user/password/?teste=1212&teste=1234\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}