const regex = /^\/([a-zA-Z\-]+\/)?(admin((\/[a-zA-Z0-9\-_&=?]*)*|$)|(user\/(login|password)(\/?\?[a-zA-Z0-9\-_&=]*|$)))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\\/([a-zA-Z\\-]+\\\/)?(admin((\\\/[a-zA-Z0-9\\-_&=?]*)*|$)|(user\\\/(login|password)(\\\/?\\?[a-zA-Z0-9\\-_&=]*|$)))$', 'gm')
const str = `/admin/valadas/gyfhsdfgsdjf/DHGSDJHFSF/sdjsdh?a=23&b=13
/user/password/?teste=1212&teste=1234
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}