use strict;
my $str = '/admin/valadas/gyfhsdfgsdjf/DHGSDJHFSF/sdjsdh?a=23&b=13
/user/password/?teste=1212&teste=1234
';
my $regex = qr/^\/([a-zA-Z\-]+\/)?(admin((\/[a-zA-Z0-9\-_&=?]*)*|$)|(user\/(login|password)(\/?\?[a-zA-Z0-9\-_&=]*|$)))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}