#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\/([a-zA-Z\-]+\/)?(admin((\/[a-zA-Z0-9\-_&=?]*)*|$)|(user\/(login|password)(\/?\?[a-zA-Z0-9\-_&=]*|$)))$"
Local $sString = "/admin/valadas/gyfhsdfgsdjf/DHGSDJHFSF/sdjsdh?a=23&b=13" & @CRLF & _
"" & @CRLF & _
"/user/password/?teste=1212&teste=1234" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")