// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<name>([^<]*?)<\/name>[\s\S]*?<size>([^<]*?)<\/size>").unwrap();
let string = "<env:Envelope xmlns:env=\"http://schemas.xmlsoap.org/soap/envelope/\">
<env:Header/>
<env:Body>
<ns2:getListsInfoResponse xmlns:ns2=\"http://service.admin.ws.five9.com/\">
<return>
<name>QuotaView</name>
<size>4</size>
</return>
</ns2:getListsInfoResponse>
</env:Body>
</env:Envelope>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}