const regex = /<name>([^<]*?)<\/name>[\s\S]*?<size>([^<]*?)<\/size>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<name>([^<]*?)<\\\/name>[\\s\\S]*?<size>([^<]*?)<\\\/size>', 'gm')
const str = `<env:Envelope xmlns:env="http://schemas.xmlsoap.org/soap/envelope/">
<env:Header/>
<env:Body>
<ns2:getListsInfoResponse xmlns:ns2="http://service.admin.ws.five9.com/">
<return>
<name>QuotaView</name>
<size>4</size>
</return>
</ns2:getListsInfoResponse>
</env:Body>
</env:Envelope>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}