re = /<name>([^<]*?)<\/name>[\s\S]*?<size>([^<]*?)<\/size>/m
str = '<env:Envelope xmlns:env="http://schemas.xmlsoap.org/soap/envelope/">
<env:Header/>
<env:Body>
<ns2:getListsInfoResponse xmlns:ns2="http://service.admin.ws.five9.com/">
<return>
<name>QuotaView</name>
<size>4</size>
</return>
</ns2:getListsInfoResponse>
</env:Body>
</env:Envelope>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end