import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<name>([^<]*?)<\\/name>[\\s\\S]*?<size>([^<]*?)<\\/size>";
final String string = "<env:Envelope xmlns:env=\"http://schemas.xmlsoap.org/soap/envelope/\">\n"
+ " <env:Header/>\n"
+ " <env:Body>\n"
+ " <ns2:getListsInfoResponse xmlns:ns2=\"http://service.admin.ws.five9.com/\">\n"
+ " <return>\n"
+ " <name>QuotaView</name>\n"
+ " <size>4</size>\n"
+ " </return>\n"
+ " </ns2:getListsInfoResponse>\n"
+ " </env:Body>\n"
+ "</env:Envelope>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}