package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<name>([^<]*?)<\/name>[\s\S]*?<size>([^<]*?)<\/size>`)
var str = `<env:Envelope xmlns:env="http://schemas.xmlsoap.org/soap/envelope/">
<env:Header/>
<env:Body>
<ns2:getListsInfoResponse xmlns:ns2="http://service.admin.ws.five9.com/">
<return>
<name>QuotaView</name>
<size>4</size>
</return>
</ns2:getListsInfoResponse>
</env:Body>
</env:Envelope>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}