$re = '/<name>([^<]*?)<\/name>[\s\S]*?<size>([^<]*?)<\/size>/m';
$str = '<env:Envelope xmlns:env="http://schemas.xmlsoap.org/soap/envelope/">
<env:Header/>
<env:Body>
<ns2:getListsInfoResponse xmlns:ns2="http://service.admin.ws.five9.com/">
<return>
<name>QuotaView</name>
<size>4</size>
</return>
</ns2:getListsInfoResponse>
</env:Body>
</env:Envelope>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);