import Foundation
let pattern = #"defmodule ([a-zA-Z]+) do\n([\s\S]*)end"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
defmodule Test do
def dupa(a, b) do
a + b
end
end
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}