// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"defmodule ([a-zA-Z]+) do\n([\s\S]*)end").unwrap();
let string = "defmodule Test do
def dupa(a, b) do
a + b
end
end";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}