const regex = /defmodule ([a-zA-Z]+) do\n([\s\S]*)end/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('defmodule ([a-zA-Z]+) do\\n([\\s\\S]*)end', '')
const str = `defmodule Test do
def dupa(a, b) do
a + b
end
end`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}