using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"defmodule ([a-zA-Z]+) do\n([\s\S]*)end";
string input = @"defmodule Test do
def dupa(a, b) do
a + b
end
end";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}