re = /defmodule ([a-zA-Z]+) do\n([\s\S]*)end/
str = 'defmodule Test do
def dupa(a, b) do
a + b
end
end'
# Print the match result
str.match(re) do |match|
puts match.to_s
end