import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "defmodule ([a-zA-Z]+) do\\n([\\s\\S]*)end";
final String string = "defmodule Test do\n"
+ " def dupa(a, b) do\n"
+ " a + b\n"
+ " end\n"
+ "end";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}