import Foundation
let pattern = #"ssl[.]{0,1}verify[ -_\"']{1,6}false['\"\\]{0,3}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
Верный текст:
some textssl.verify: false some text
git config http.sslVerify "false"
some textssl.verify: false" some text
some text = "sslVerify \"false\"" some text
some text = "sslVerify \"false\"" some text
some text = sslVerify=false"some text
some text = "sslVerify 'false' some text
some text.sslVerify=\"false\"" some text
some text"sslVerify = \"false\""some text
Не должно проходить валидацию:
some text"sslVerify = some text \"false\""some text
some text"ssl Verify = "false""some text
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)