import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ssl[.]{0,1}verify[ -_\\\"']{1,6}false['\\\"\\\\]{0,3}";
final String string = "Верный текст:\n"
+ "some textssl.verify: false some text\n"
+ " git config http.sslVerify \"false\"\n"
+ "some textssl.verify: false\" some text\n"
+ "some text = \"sslVerify \\\"false\\\"\" some text\n"
+ "some text = \"sslVerify \\\"false\\\"\" some text\n"
+ "some text = sslVerify=false\"some text\n"
+ "some text = \"sslVerify 'false' some text\n"
+ "some text.sslVerify=\\\"false\\\"\" some text\n"
+ "some text\"sslVerify = \\\"false\\\"\"some text\n\n\n"
+ "Не должно проходить валидацию:\n"
+ "some text\"sslVerify = some text \\\"false\\\"\"some text\n"
+ "some text\"ssl Verify = \"false\"\"some text\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}