using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ssl[.]{0,1}verify[ -_\""']{1,6}false['\""\\]{0,3}";
string input = @"Верный текст:
some textssl.verify: false some text
git config http.sslVerify ""false""
some textssl.verify: false"" some text
some text = ""sslVerify \""false\"" some text
some text = ""sslVerify \""false\"" some text
some text = sslVerify=false""some text
some text = ""sslVerify 'false' some text
some text.sslVerify=\""false\"" some text
some text""sslVerify = \""false\""some text
Не должно проходить валидацию:
some text""sslVerify = some text \""false\""some text
some text""ssl Verify = ""false""some text
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}