$re = '/ssl[.]{0,1}verify[ -_\"\']{1,6}false[\'\"\\\\]{0,3}/i';
$str = 'Верный текст:
some textssl.verify: false some text
git config http.sslVerify "false"
some textssl.verify: false" some text
some text = "sslVerify \\"false\\"" some text
some text = "sslVerify \\"false\\"" some text
some text = sslVerify=false"some text
some text = "sslVerify \'false\' some text
some text.sslVerify=\\"false\\"" some text
some text"sslVerify = \\"false\\""some text
Не должно проходить валидацию:
some text"sslVerify = some text \\"false\\""some text
some text"ssl Verify = "false""some text
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);