use strict;
my $str = 'Верный текст:
some textssl.verify: false some text
git config http.sslVerify "false"
some textssl.verify: false" some text
some text = "sslVerify \\"false\\"" some text
some text = "sslVerify \\"false\\"" some text
some text = sslVerify=false"some text
some text = "sslVerify \'false\' some text
some text.sslVerify=\\"false\\"" some text
some text"sslVerify = \\"false\\""some text
Не должно проходить валидацию:
some text"sslVerify = some text \\"false\\""some text
some text"ssl Verify = "false""some text
';
my $regex = qr/ssl[.]{0,1}verify[ -_\"']{1,6}false['\"\\]{0,3}/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}