const regex = /ssl[.]{0,1}verify[ -_\"']{1,6}false['\"\\]{0,3}/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('ssl[.]{0,1}verify[ -_\\"\']{1,6}false[\'\\"\\\\]{0,3}', 'gi')
const str = `Верный текст:
some textssl.verify: false some text
git config http.sslVerify "false"
some textssl.verify: false" some text
some text = "sslVerify \\"false\\"" some text
some text = "sslVerify \\"false\\"" some text
some text = sslVerify=false"some text
some text = "sslVerify 'false' some text
some text.sslVerify=\\"false\\"" some text
some text"sslVerify = \\"false\\""some text
Не должно проходить валидацию:
some text"sslVerify = some text \\"false\\""some text
some text"ssl Verify = "false""some text
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}