re = /(abandon)(ar(d?es|em|mos)?)/m
str = 'por abandonar eu
por abandonares tu
por abandonar ele
por abandonarmos nós
por abandonardes vós
por abandonarem eles'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end