const regex = /(abandon)(ar(d?es|em|mos)?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(abandon)(ar(d?es|em|mos)?)', 'gm')
const str = `por abandonar eu
por abandonares tu
por abandonar ele
por abandonarmos nós
por abandonardes vós
por abandonarem eles`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}